New AMD driver

Message boards : Bug reports : New AMD driver

To post messages, you must log in.

AuthorMessage
Darrell
Avatar

Send message
Joined: 27 Feb 10
Posts: 4
Credit: 4,252,718
RAC: 5,554
Message 6313 - Posted: 22 Aug 2017, 1:44:26 UTC

Upgraded to the new AMD driver version 17.8.1 and now the Enigma tasks are failing with code 195 EXIT_CHILD_FAILED. Checked the other projects, and no other project is having an issue with the new driver.
ID: 6313 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Darrell
Avatar

Send message
Joined: 27 Feb 10
Posts: 4
Credit: 4,252,718
RAC: 5,554
Message 6394 - Posted: 13 Sep 2017, 3:39:16 UTC
Last modified: 13 Sep 2017, 3:43:53 UTC

After going back to 17.7.1 for awhile so that the Enigma GPU tasks would run, upgraded to the latest driver tonight 17.9.1 and everything is running fine.
... and still I fear, and still I dare not laugh at the Mad Man!

Queen - The Prophet's Song
ID: 6394 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dirk Broer

Send message
Joined: 15 Aug 12
Posts: 19
Credit: 2,731,130
RAC: 223
Message 6437 - Posted: 15 Sep 2017, 20:21:05 UTC
Last modified: 15 Sep 2017, 20:21:41 UTC

I have a FM1 board with a HD 6670 and the HD 6550D of an A8-3820 APU.
I am running the most recent AMD driver for that setup, which is 16.2.1
All WUs exceed the time limit since a week or so, before that all was running well.
ID: 6437 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dirk Broer

Send message
Joined: 15 Aug 12
Posts: 19
Credit: 2,731,130
RAC: 223
Message 6607 - Posted: 24 Sep 2017, 8:13:44 UTC - in response to Message 6437.  

Another system uses Ubuntu 16.04, which can't use the AMD Driver anymore and has an Open Source video driver, that works on e.g. Xansons for COD.
Enigma WUs fail though because Preferred OpenCL platform vendor (Advanced Micro Devices, Inc.) not found.
ID: 6607 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,176,588
RAC: 394,077
Message 6608 - Posted: 24 Sep 2017, 9:18:43 UTC - in response to Message 6607.  

Matszpk (the OpenCL port author) said he will look at the possibility to support open source driver.
The current version is highly optimized for AMD OpenCL and that's why it's refusing to run on other platforms.
M4 Project homepage
M4 Project wiki
ID: 6608 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
matszpk
Project tester
Volunteer developer
Volunteer tester

Send message
Joined: 20 May 11
Posts: 8
Credit: 7,728,083
RAC: 141,712
Message 6613 - Posted: 26 Sep 2017, 19:46:06 UTC

I have version that working under opensource driver. Maybe tomorrow, that version will be given to tests. It can be working on old
Mesa3D/LLVM and new Mesa3D/LLVM (LLVM >=4.0.0). Also, I added support for Polaris to my assembler (and that version), so that version
will be working on RX 4x0/5x0 graphics cards.
ID: 6613 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Darrell
Avatar

Send message
Joined: 27 Feb 10
Posts: 4
Credit: 4,252,718
RAC: 5,554
Message 6614 - Posted: 28 Sep 2017, 0:01:53 UTC

Upgraded to the latest driver last night, 17.9.2 and the Enigma tasks are running. Note: I should have said earlier that even though they run now on these new drivers, The Progress indicator does not update for about the first 50 seconds or so the task is running and when it does, the task is then at about 25% complete and the Progress indicator indicates normally until the task ends.
... and still I fear, and still I dare not laugh at the Mad Man!

Queen - The Prophet's Song
ID: 6614 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
matszpk
Project tester
Volunteer developer
Volunteer tester

Send message
Joined: 20 May 11
Posts: 8
Credit: 7,728,083
RAC: 141,712
Message 6616 - Posted: 29 Sep 2017, 5:01:41 UTC

I encountered some problems while testing on new open-source drivers (Mesa3D 17.0.0 and LLVM 4.0) on my new hardware (RX 480). I need time to troubleshooting. Luckily, main assembly code works very well on opensource drivers (without errors). Only some OpenCL code needs revision.
ID: 6616 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,176,588
RAC: 394,077
Message 13236 - Posted: 4 Oct 2017, 19:30:38 UTC - in response to Message 6614.  

The Progress indicator does not update for about the first 50 seconds or so the task is running and when it does, the task is then at about 25% complete and the Progress indicator indicates normally until the task ends.


The progress reporting is not currently supported by the GPU apps as they run via wrapper.
The BOINC core client guesses the runtime after a few WUs and then the default progress info seems to fairly accurate.
M4 Project homepage
M4 Project wiki
ID: 13236 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,176,588
RAC: 394,077
Message 13237 - Posted: 4 Oct 2017, 19:35:08 UTC - in response to Message 6616.  
Last modified: 4 Oct 2017, 19:37:34 UTC

I encountered some problems while testing on new open-source drivers (Mesa3D 17.0.0 and LLVM 4.0) on my new hardware (RX 480). I need time to troubleshooting. Luckily, main assembly code works very well on opensource drivers (without errors). Only some OpenCL code needs revision.


I'll be releasing matszpk's latest app version under the test platform later today as Enigma GPU test v1.08.
M4 Project homepage
M4 Project wiki
ID: 13237 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Bug reports : New AMD driver




Copyright © 2017 TJM