EXIT_CHILD_FAILED (lots of them)

Message boards : Number crunching : EXIT_CHILD_FAILED (lots of them)

To post messages, you must log in.

AuthorMessage
Kwartet!

Send message
Joined: 28 Jul 15
Posts: 5
Credit: 14,295,109
RAC: 111,120
Message 13538 - Posted: 12 Nov 2017, 11:43:18 UTC
Last modified: 12 Nov 2017, 11:45:12 UTC

This wu: http://www.enigmaathome.net/workunit.php?wuid=303677200

Wingman succeeds: http://www.enigmaathome.net/result.php?resultid=327646286

My task errors with this code: 195 (0x000000C3) EXIT_CHILD_FAILED
http://www.enigmaathome.net/result.php?resultid=319423739
<core_client_version>7.6.33</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code 195 (0xc3)
</message>
<stderr_txt>
wrapper [26118 770 +dev#, opencl_ati_101]: starting (GPU #0)
20:33:39 (5800): wrapper: running enigma_opencl.exe (-d 0 -R -o results.txt 04trigr.cur 04unigr.cur 04ciphertext)
app exit status: 0x1
20:33:40 (5800): called boinc_finish
</stderr_txt>
]]>

Previous wu: http://www.enigmaathome.net/workunit.php?wuid=303668242
Success on my pc: http://www.enigmaathome.net/result.php?resultid=319414785
<core_client_version>7.6.33</core_client_version>
<![CDATA[
<stderr_txt>
wrapper [26118 770 +dev#, opencl_ati_101]: starting (GPU #0)
15:38:13 (6320): wrapper: running enigma_opencl.exe (-d 0 -R -o results.txt 04trigr.cur 04unigr.cur 04ciphertext)
Found GPU 0: 'Tahiti', Board name: 'AMD Radeon HD 7900 Series', Compute units: 28
AMD OpenCL 1.2 format 32-bit
GCN version: GCN 1.0
GCN Assembly Optimization 0.2
15:48:26 (6320): called boinc_finish
</stderr_txt>
]]>

Difference between success and fail: "Found GPU...". Seems Enigma doesn't see my HD7950 anymore.

I'm on Windows 7, may have reread local config files, and sure didn't change anything relating to Enigma. Other project (Amicable numbers) runs OK.

Radeon Settings Version - 2017.0720.1902.32426
Driver Packaging Version - 17.30.1041-170720a-316469C-CrimsonReLive
Provider - Advanced Micro Devices, Inc.
2D Driver Version - 8.1.1.1614
Direct3D® Version - 9.14.10.01292
OpenGL® Version - 6.14.10.13491
OpenCL™ Version - 22.19.662.4
AMD Mantle Version - 9.1.10.0220
AMD Mantle API Version - 102400
AMD Audio Driver Version - 7.12.0.7725
Vulkan™ Driver Version - 1.6.0
Vulkan™ API Version - 1.0.51
ID: 13538 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Helix Von Smelix

Send message
Joined: 31 Oct 07
Posts: 35
Credit: 609,233,560
RAC: 4,846,964
Message 13541 - Posted: 13 Nov 2017, 22:40:59 UTC

Amicable numbers made my install go kabonkers.

Had to completely remove and reinstall to sort enigma again.
ID: 13541 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Kwartet!

Send message
Joined: 28 Jul 15
Posts: 5
Credit: 14,295,109
RAC: 111,120
Message 13543 - Posted: 15 Nov 2017, 9:41:17 UTC - in response to Message 13541.  

Helix, weird stuff. How could Amicable interfere with an existing install of Enigma? I know it doesn't touch anything inside Enigma's project directory. And doing its stuff in the BOINC directory, notably adding some lines to cc_config.xml in is not that error-prone.

Anyhow, after running Windows update last night and a clean install of new videodrivers (now on 1.17.11), Enigma runs fine again on my GPU.
ID: 13543 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Number crunching : EXIT_CHILD_FAILED (lots of them)




Copyright © 2017 TJM