Upload handler missing.

Message boards : Bug reports : Upload handler missing.

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
Drudge

Send message
Joined: 11 Apr 09
Posts: 18
Credit: 568,771
RAC: 0
Message 1004 - Posted: 3 Jun 2009, 9:14:24 UTC

I have a growing queue of completed exponents. They haven't been uploaded and the message is: "project file upload handler is missing".

First apparent about 2100 GMT 2nd June 2009. Any suggestions?
"Verloren ist nur, wer sich selbst aufgibt."
ID: 1004 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile kevint

Send message
Joined: 21 Oct 07
Posts: 2
Credit: 506,031
RAC: 0
Message 1009 - Posted: 3 Jun 2009, 13:10:09 UTC - in response to Message 1004.  

Same here..


6/3/2009 06:49:48|Enigma@Home|[error] Couldn't find suitable URL for hceyz72_1_6893895_r0_0_0
6/3/2009 06:49:48||[error] No URL for file transfer of hceyz72_1_6893895_r0_0_0
6/3/2009 06:49:49|Enigma@Home|Started upload of hceyz72_1_6893895_r0_0_0
6/3/2009 06:49:51|Enigma@Home|Project file upload handler is missing
6/3/2009 06:49:51|Enigma@Home|Backing off 1 min 0 sec on upload of hceyz72_1_6893895_r0_0_0
ID: 1009 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1010 - Posted: 3 Jun 2009, 13:36:03 UTC - in response to Message 1009.  

ID: 1010 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile maniek_77

Send message
Joined: 3 Nov 07
Posts: 7
Credit: 71,409
RAC: 0
Message 1012 - Posted: 3 Jun 2009, 19:25:02 UTC - in response to Message 1010.  

Fixed (I hope).



Nope (I guess).

2009-06-03 20:58:11|Enigma@Home|Started upload of hceyz72_0_6909931_r0_0_0
2009-06-03 20:58:12|Enigma@Home|Project file upload handler is missing
2009-06-03 20:58:12|Enigma@Home|Backing off 1 min 0 sec on upload of hceyz72_0_6909931_r0_0_0
2009-06-03 20:59:12|Enigma@Home|Started upload of hceyz72_0_6909931_r0_0_0
2009-06-03 20:59:14|Enigma@Home|Temporarily failed upload of hceyz72_0_6909931_r0_0_0: HTTP error
2009-06-03 20:59:14|Enigma@Home|Backing off 1 min 0 sec on upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:00:14|Enigma@Home|Started upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:00:18|Enigma@Home|Temporarily failed upload of hceyz72_0_6909931_r0_0_0: HTTP error
2009-06-03 21:00:18|Enigma@Home|Backing off 1 min 0 sec on upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:01:19|Enigma@Home|Started upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:01:27|Enigma@Home|Project file upload handler is missing
2009-06-03 21:01:27|Enigma@Home|Backing off 1 min 52 sec on upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:03:21|Enigma@Home|Started upload of hceyz72_0_6909931_r0_0_0
2009-06-03 21:03:23|Enigma@Home|Project file upload handler is missing
2009-06-03 21:03:23|Enigma@Home|Backing off 5 min 56 sec on upload of hceyz72_0_6909931_r0_0_0
ID: 1012 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1013 - Posted: 3 Jun 2009, 19:55:38 UTC - in response to Message 1012.  

Hm still doesn't work ? I've just checked upload URLs (the correct one, and the previous, bugged also) and all are working...
M4 Project homepage
M4 Project wiki
ID: 1013 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Drudge

Send message
Joined: 11 Apr 09
Posts: 18
Credit: 568,771
RAC: 0
Message 1017 - Posted: 3 Jun 2009, 20:03:37 UTC - in response to Message 1013.  

Working for me now, thanks.

Thanks too for the prompt and positive response. :)
"Verloren ist nur, wer sich selbst aufgibt."
ID: 1017 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1196 - Posted: 4 Sep 2009, 5:57:59 UTC

Since a few days I have this problem:

03.09.2009 16:32:46|Enigma@Home|Started upload of awgly100_1_xXEd_0_0_0
03.09.2009 16:32:54|Enigma@Home|Project file upload handler is missing
03.09.2009 16:32:54|Enigma@Home|Backing off 1 hr 16 min 10 sec on upload of awgly100_1_xXEd_0_0_0
03.09.2009 16:32:54|Enigma@Home|Started upload of awgly100_0_ypLX_0_0_0
03.09.2009 16:33:00|Enigma@Home|Project file upload handler is missing
03.09.2009 16:33:00|Enigma@Home|Backing off 2 hr 19 min 35 sec on upload of awgly100_0_ypLX_0_0_0
03.09.2009 16:33:00|Enigma@Home|Started upload of awgly100_0_ypAK_0_0_0
03.09.2009 16:33:06|Enigma@Home|Project file upload handler is missing
03.09.2009 16:33:06|Enigma@Home|Backing off 22 min 42 sec on upload of awgly100_0_ypAK_0_0_0
03.09.2009 16:33:06|Enigma@Home|Started upload of awgly100_0_AhRb_0_0_0
03.09.2009 16:33:14|Enigma@Home|Project file upload handler is missing
03.09.2009 16:33:14|Enigma@Home|Backing off 59 min 52 sec on upload of awgly100_0_AhRb_0_0_0
03.09.2009 16:33:14|yoyo@home|Started upload of ogr_090901161503_32_0_0
03.09.2009 16:33:33|yoyo@home|Finished upload of ogr_090901161503_32_0_0
03.09.2009 16:33:33|yoyo@home|Started upload of ogr_090901161503_32_0_1
03.09.2009 16:34:18|yoyo@home|Finished upload of ogr_090901161503_32_0_1
03.09.2009 16:34:18|yoyo@home|Started upload of ogr_090901062505_61_0_0
03.09.2009 16:34:32|yoyo@home|Finished upload of ogr_090901062505_61_0_0

That does not happen with all of the Enigma WUs. Some Enigma WUs can be uploaded, others not. But there are always the same that can not be uploaded since a few days. I have the problem on three computers.

Am I the only one with the problem? Has anyone an idea what I can do?

Thanks, Grubix.
ID: 1196 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1201 - Posted: 4 Sep 2009, 17:42:20 UTC - in response to Message 1196.  
Last modified: 4 Sep 2009, 17:42:58 UTC

Could you enable additional log entries in cc_config ?


The start and completion of file transfers.

Show completion status of file transfers.

Debugging information about HTTP operations.

Debugging information about network communication.

http://boinc.berkeley.edu/wiki/Client_configuration

I'm not sure which one will display info about uploads, but it should be safe to enable all at once.
M4 Project homepage
M4 Project wiki
ID: 1201 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1206 - Posted: 5 Sep 2009, 21:33:00 UTC

Hello TJM, i send you a PN.

Bye, Grubix.
ID: 1206 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1207 - Posted: 5 Sep 2009, 22:22:35 UTC

From the log, I see that you're using http proxy. Could you check, if you can access the upload handler directly in the web browser (I'm assuming that your browser uses the same proxy) ? It's here: http://www.enigmaathome.net/file_upload_handler
It should display something like this:



1
no command



The log looks quite interesting, nothing seems to be wrong there, after some header exchange the BOINC Core suddenly says that the file upload handler is missing. IMO it would be good to strip the IP/hostnames from the log file and post it to the public, then we'll be able to ask BOINC devs what they think about it.



M4 Project homepage
M4 Project wiki
ID: 1207 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1210 - Posted: 6 Sep 2009, 15:51:01 UTC - in response to Message 1207.  

From the log, I see that you're using http proxy...

Yes, that's right. For these computers it is the only way into the Internet. I will run the test and write what I get. I can do this not before Tuesday, sorry. The computers are not home...

Bye, Grubix.
ID: 1210 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
MoDifiy

Send message
Joined: 20 Jul 08
Posts: 3
Credit: 107,036,027
RAC: 572,723
Message 1222 - Posted: 8 Sep 2009, 12:59:22 UTC

I am having this same issue as the others in this post with some of the work units, but not all. I have quite a few now that give project file upload handler is missing. I just upgraded to the latest boinc client to see if that would help and no change.

9/8/2009 9:56:13 AM Enigma@Home Backing off 1 hr 0 min 10 sec on upload of awgly100_0_zSLB_0_0_0
9/8/2009 9:56:13 AM Enigma@Home Started upload of awgly100_0_zSen_0_0_0
9/8/2009 9:56:13 AM Enigma@Home Started upload of awgly100_0_zShR_0_0_0
9/8/2009 9:56:14 AM Enigma@Home Project file upload handler is missing
9/8/2009 9:56:14 AM Enigma@Home Backing off 1 hr 24 min 10 sec on upload of awgly100_0_zSen_0_0_0
9/8/2009 9:56:14 AM Enigma@Home Started upload of awgly100_0_zSLf_0_0_0
9/8/2009 9:56:15 AM Enigma@Home Project file upload handler is missing
9/8/2009 9:56:15 AM Enigma@Home Backing off 2 hr 33 min 34 sec on upload of awgly100_0_zShR_0_0_0
9/8/2009 9:56:15 AM Enigma@Home Project file upload handler is missing
9/8/2009 9:56:15 AM Enigma@Home Backing off 3 hr 0 min 2 sec on upload of awgly100_0_zSLf_0_0_0
9/8/2009 9:56:15 AM Enigma@Home Started upload of awgly100_0_zSLQ_0_0_0
9/8/2009 9:56:16 AM Enigma@Home Project file upload handler is missing
9/8/2009 9:56:16 AM Enigma@Home Backing off 1 hr 35 min 33 sec on upload of awgly100_0_zSLQ_0_0_0
ID: 1222 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1224 - Posted: 9 Sep 2009, 14:50:28 UTC - in response to Message 1207.  

... Could you check, if you can access the upload handler directly in the web browser (I'm assuming that your browser uses the same proxy) ?

The browser uses the same proxy. When I enter the address, I get the message that you mention.

<data_server_reply>
    <status>1</status>
    <message>no command</message>
</data_server_reply>


I try to describe how the upload looks. But in English it is not easy for me:

A working upload:
-----------------
1. The WU is e.g. at 0 / 116 bytes.
2. The transmission starts, it sends a request to Enigma.
3. I get a response from the server.
4. Data is sent to the server.
5. The display switches to 116/116 byte.
6. I get a response from the server.
7. The WU is uploaded and disappears from the display.

A not working upload:
---------------------
1. The WU is e.g. at 0 / 116 bytes.
2. The transmission starts, it sends a request to Enigma.
3. I get a response from the server.
4. The display switches to 114/116 byte or 323/116 byte (see screenshot)
6. I get the "Project file upload handler is missing" message.






There are currently about 10% of the WUs are concerned, the other 90% will be uploaded without difficulty.


... post it to the public ...

A working upload:
-----------------

08.09.2009 05:50:58||[http_debug] HTTP_OP::libcurl_exec(): ca-bundle 'C:\Programme\BOINC\ca-bundle.crt'
08.09.2009 05:50:58||[http_debug] HTTP_OP::libcurl_exec(): ca-bundle set
08.09.2009 05:50:58|Enigma@Home|Started upload of awgly100_0_AhZi_0_0_0
08.09.2009 05:50:58||[file_xfer_debug] URL: http://www.enigmaathome.net/file_upload_handler
08.09.2009 05:50:59||[http_debug] [ID#161] info: timeout on name lookup is not supported
08.09.2009 05:50:59||[http_debug] [ID#161] info: About to connect() to proxy xx.xx.xx.xx port 3128 (#0)
08.09.2009 05:50:59||[http_debug] [ID#161] info:   Trying xx.xx.xx.xx... 
08.09.2009 05:51:00||[http_debug] [ID#161] info: Connected to xx.xx.xx.xx (xx.xx.xx.xx) port 3128 (#0)
08.09.2009 05:51:00||[http_debug] [ID#161] Sent header to server: POST http://www.enigmaathome.net/file_upload_handler HTTP/1.0
User-Agent: BOINC client (windows_intelx86 6.4.7)
Host: www.enigmaathome.net
Accept: */*
Accept-Encoding: deflate, gzip
Proxy-Connection: Keep-Alive
Content-Type: application/x-www-form-urlencoded
Content-Length: 273
08.09.2009 05:51:04||[http_debug] [ID#161] info: HTTP 1.0, assume close after body
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: HTTP/1.0 200 OK
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Date: Tue, 08 Sep 2009 01:50:53 GMT
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Server: Apache/2.2.3 (Debian) mod_fastcgi/2.4.2 PHP/5.2.0-8+etch15
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Vary: Accept-Encoding
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Content-Encoding: gzip
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Content-Type: text/plain; charset=UTF-8
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Accept-Encoding: deflate, gzip, x-gzip
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: X-Cache: MISS from xxxxxxxx.xxx.xx
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: X-Cache-Lookup: MISS from xxxxxxxx.xxx.xx:3128
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Via: 1.1 xxxxxxxx.xxx.xx:3128 (squid/2.7.STABLE3)
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: Connection: close
08.09.2009 05:51:04||[http_debug] [ID#161] Received header from server: 
08.09.2009 05:51:04||[http_xfer_debug] HTTP: wrote 93 bytes
08.09.2009 05:51:04||[http_debug] [ID#161] info: Expire cleared
08.09.2009 05:51:04||[http_debug] [ID#161] info: Closing connection #0
08.09.2009 05:51:05||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval 0
08.09.2009 05:51:05|Enigma@Home|[file_xfer_debug] parsing upload response: <data_server_reply>    <status>0</status>    <file_size>0</file_size></data_server_reply>
08.09.2009 05:51:05|Enigma@Home|[file_xfer_debug] parsing status: 0
08.09.2009 05:51:05||[http_debug] HTTP_OP::libcurl_exec(): ca-bundle set
08.09.2009 05:51:06||[http_debug] [ID#162] info: timeout on name lookup is not supported
08.09.2009 05:51:06||[http_debug] [ID#162] info: About to connect() to proxy xx.xx.xx.xx port 3128 (#0)
08.09.2009 05:51:06||[http_debug] [ID#162] info:   Trying xx.xx.xx.xx... 
08.09.2009 05:51:07||[http_debug] [ID#162] info: Connected to xx.xx.xx.xx (xx.xx.xx.xx) port 3128 (#0)
08.09.2009 05:51:07||[http_debug] [ID#162] Sent header to server: POST http://www.enigmaathome.net/file_upload_handler HTTP/1.0
User-Agent: BOINC client (windows_intelx86 6.4.7)
Host: www.enigmaathome.net
Accept: */*
Accept-Encoding: deflate, gzip
Proxy-Connection: Keep-Alive
Content-Type: application/x-www-form-urlencoded
Content-Length: 910
08.09.2009 05:51:13||[http_debug] [ID#162] info: HTTP 1.0, assume close after body
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: HTTP/1.0 200 OK
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Date: Tue, 08 Sep 2009 01:51:02 GMT
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Server: Apache/2.2.3 (Debian) mod_fastcgi/2.4.2 PHP/5.2.0-8+etch15
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Vary: Accept-Encoding
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Content-Encoding: gzip
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Content-Type: text/plain; charset=UTF-8
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Accept-Encoding: deflate, gzip, x-gzip
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: X-Cache: MISS from xxxxxxxx.xxx.xx
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: X-Cache-Lookup: MISS from xxxxxxxx.xxx.xx:3128
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Via: 1.1 xxxxxxxx.xxx.xx:3128 (squid/2.7.STABLE3)
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: Connection: close
08.09.2009 05:51:13||[http_debug] [ID#162] Received header from server: 
08.09.2009 05:51:13||[http_xfer_debug] HTTP: wrote 64 bytes
08.09.2009 05:51:13||[http_debug] [ID#162] info: Expire cleared
08.09.2009 05:51:13||[http_debug] [ID#162] info: Closing connection #0
08.09.2009 05:51:14||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval 0
08.09.2009 05:51:14|Enigma@Home|[file_xfer_debug] parsing upload response: <data_server_reply>    <status>0</status></data_server_reply>
08.09.2009 05:51:14|Enigma@Home|[file_xfer_debug] parsing status: 0
08.09.2009 05:51:14||[file_xfer_debug] file transfer status 0
08.09.2009 05:51:14|Enigma@Home|Finished upload of awgly100_0_AhZi_0_0_0
08.09.2009 05:51:14|Enigma@Home|[file_xfer_debug] Throughput 21 bytes/sec




A not working upload:
---------------------

05.09.2009 09:21:30||[http_debug] HTTP_OP::libcurl_exec(): ca-bundle 'C:\Programme\BOINC\ca-bundle.crt'
05.09.2009 09:21:30||[http_debug] HTTP_OP::libcurl_exec(): ca-bundle set
05.09.2009 09:21:30|Enigma@Home|Started upload of awgly100_0_ypLX_0_0_0
05.09.2009 09:21:30||[file_xfer_debug] URL: http://www.enigmaathome.net/file_upload_handler
05.09.2009 09:21:30||[http_debug] [ID#15] info: timeout on name lookup is not supported
05.09.2009 09:21:30||[http_debug] [ID#15] info: About to connect() to proxy xx.xx.xx.xx port 3128 (#0)
05.09.2009 09:21:30||[http_debug] [ID#15] info:   Trying xx.xx.xx.xx... 
05.09.2009 09:21:32||[http_debug] [ID#15] info: Connected to xx.xx.xx.xx (xx.xx.xx.xx) port 3128 (#0)
05.09.2009 09:21:32||[http_debug] [ID#15] Sent header to server: POST http://www.enigmaathome.net/file_upload_handler HTTP/1.0
User-Agent: BOINC client (windows_intelx86 6.4.7)
Host: www.enigmaathome.net
Accept: */*
Accept-Encoding: deflate, gzip
Proxy-Connection: Keep-Alive
Content-Type: application/x-www-form-urlencoded
Content-Length: 273
05.09.2009 09:21:36||[http_debug] [ID#15] info: HTTP 1.0, assume close after body
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: HTTP/1.0 200 OK
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Date: Sat, 05 Sep 2009 05:21:05 GMT
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Server: Apache/2.2.3 (Debian) mod_fastcgi/2.4.2 PHP/5.2.0-8+etch15
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Vary: Accept-Encoding
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Content-Encoding: gzip
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Content-Type: text/plain; charset=UTF-8
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Accept-Encoding: deflate, gzip, x-gzip
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: X-Cache: MISS from xxxxxxxx.xxx.xx
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: X-Cache-Lookup: MISS from xxxxxxxx.xxx.xx:3128
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Via: 1.1 xxxxxxxx.xxx.xx:3128 (squid/2.7.STABLE3)
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: Connection: close
05.09.2009 09:21:36||[http_debug] [ID#15] Received header from server: 
05.09.2009 09:21:37||[http_xfer_debug] HTTP: wrote 95 bytes
05.09.2009 09:21:37||[http_debug] [ID#15] info: Expire cleared
05.09.2009 09:21:37||[http_debug] [ID#15] info: Closing connection #0
05.09.2009 09:21:37||[file_xfer_debug] FILE_XFER_SET::poll(): http op done; retval 0
05.09.2009 09:21:37|Enigma@Home|[file_xfer_debug] parsing upload response: <data_server_reply>    <status>0</status>    <file_size>110</file_size></data_server_reply>
05.09.2009 09:21:37|Enigma@Home|[file_xfer_debug] parsing status: 0
05.09.2009 09:21:37||[file_xfer_debug] file transfer status -161
05.09.2009 09:21:37|Enigma@Home|Project file upload handler is missing
05.09.2009 09:21:37|Enigma@Home|Backing off 3 hr 31 min 52 sec on upload of awgly100_0_ypLX_0_0_0



Bye, Grubix.
ID: 1224 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
BitCracker

Send message
Joined: 4 Sep 09
Posts: 1
Credit: 2,244,131
RAC: 0
Message 1228 - Posted: 10 Sep 2009, 14:21:23 UTC

I've been receiving the same error. Currently I have 13 files giving this error.
ID: 1228 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1231 - Posted: 11 Sep 2009, 23:57:12 UTC - in response to Message 1228.  

I've been receiving the same error. Currently I have 13 files giving this error.


Do you use a proxy server ? Could you enable the debug flags listed above, and post the log (after stripping your IP's) ?


M4 Project homepage
M4 Project wiki
ID: 1231 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1233 - Posted: 12 Sep 2009, 13:29:17 UTC - in response to Message 1224.  


The browser uses the same proxy. When I enter the address, I get the message that you mention.


Could you check what's the external IP address of the proxy server ? I've tried grepping the httpd.log looking for the IP from the BOINC log you've sent me via PM, but it's not there. So I guess the proxy must have different internal and external IP's.
I tried searching the user-agent string (BOINC 6.4.7 windows) but that gave me way too much data.

M4 Project homepage
M4 Project wiki
ID: 1233 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1236 - Posted: 12 Sep 2009, 16:47:58 UTC - in response to Message 1233.  

The last few days, i have seen no new WUs which could not be uploaded. I will however continue to monitor.

The number of the old WUs are going now smaller. The BOINC-Client is "tired" and gives up. ;-)

11.09.2009 21:07:47|Enigma@Home|Started upload of awgly100_0_xUDb_0_0_0
11.09.2009 21:07:57|Enigma@Home|Project file upload handler is missing
11.09.2009 21:07:57|Enigma@Home|Backing off 19 min 54 sec on upload of awgly100_0_xUDb_0_0_0
11.09.2009 21:27:52|Enigma@Home|Started upload of awgly100_0_xUDb_0_0_0
11.09.2009 21:28:10|Enigma@Home|Project file upload handler is missing
11.09.2009 21:28:10|Enigma@Home|Giving up on upload of awgly100_0_xUDb_0_0_0: timeout
11.09.2009 21:28:10|Enigma@Home|Backing off 30 min 18 sec on upload of awgly100_0_xUDb_0_0_0
11.09.2009 21:28:23|Enigma@Home|Started upload of awgly100_0_xUAT_0_0_0
11.09.2009 21:28:33|Enigma@Home|Project file upload handler is missing
11.09.2009 21:28:33|Enigma@Home|Giving up on upload of awgly100_0_xUAT_0_0_0: timeout
11.09.2009 21:28:33|Enigma@Home|Backing off 1 hr 47 min 25 sec on upload of awgly100_0_xUAT_0_0_0
11.09.2009 21:28:33|Enigma@Home|Started upload of awgly100_0_xUDi_0_0_0
11.09.2009 21:28:43|Enigma@Home|Project file upload handler is missing
11.09.2009 21:28:43|Enigma@Home|Giving up on upload of awgly100_0_xUDi_0_0_0: timeout
11.09.2009 21:28:43|Enigma@Home|Backing off 3 hr 27 min 57 sec on upload of awgly100_0_xUDi_0_0_0
11.09.2009 21:28:43|Enigma@Home|Started upload of awgly100_0_xUDh_0_0_0
11.09.2009 21:29:05|Enigma@Home|Temporarily failed upload of awgly100_0_xUDh_0_0_0: connect() failed
11.09.2009 21:29:05|Enigma@Home|Giving up on upload of awgly100_0_xUDh_0_0_0: timeout
11.09.2009 21:29:05|Enigma@Home|Backing off 42 min 7 sec on upload of awgly100_0_xUDh_0_0_0
11.09.2009 21:29:05|Enigma@Home|Started upload of awgly100_0_xUBH_0_0_0
11.09.2009 21:29:40|Enigma@Home|Project file upload handler is missing
11.09.2009 21:29:40|Enigma@Home|Giving up on upload of awgly100_0_xUBH_0_0_0: timeout
11.09.2009 21:29:40|Enigma@Home|Backing off 3 hr 23 min 39 sec on upload of awgly100_0_xUBH_0_0_0


Bye, Grubix.
ID: 1236 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,330,737
RAC: 382,122
Message 1238 - Posted: 12 Sep 2009, 20:50:22 UTC - in response to Message 1236.  

The last few days, i have seen no new WUs which could not be uploaded. I will however continue to monitor.

The number of the old WUs are going now smaller. The BOINC-Client is "tired" and gives up. ;-)



Perhaps the proxy is misconfigured (or configured like that for purpose) and caches server's error replies. But I'm not sure if it's even possible to cache a post request, that would be probably violation of http standards.
I've grepped all the http logs looking for the IP you've send me, there are no sign of errors - no 404's in the access_log and no entries in the error log, everything just seems to be fine.

M4 Project homepage
M4 Project wiki
ID: 1238 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Grubix

Send message
Joined: 20 Jul 08
Posts: 44
Credit: 6,270,837
RAC: 0
Message 1239 - Posted: 12 Sep 2009, 22:48:07 UTC - in response to Message 1238.  
Last modified: 12 Sep 2009, 22:48:34 UTC

OK, many thanks for your help. If the problem comes from the proxy, then you should pardon the work I've done to you.

I have no access to the proxy. Since it is the only way to the internet for me, I can not change anything.

If you want, you can look one last time in the log. The IP is right, I have just checked again. At 22:30 UTC I have tried twice the upload from 7 WUs. Unsuccessful.

Thanks again for your help. I'm going to reset the project on all the computers. Maybe it helps. :-)

Have a nice weekend, Grubix.
ID: 1239 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
noderaser
Avatar

Send message
Joined: 24 Dec 08
Posts: 88
Credit: 629,026
RAC: 0
Message 1240 - Posted: 13 Sep 2009, 2:40:55 UTC

You DO have permission to be running BOINC on these computers, don't you?

Just a side comment I pulled out from way back in my brain.

ID: 1240 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
1 · 2 · Next

Message boards : Bug reports : Upload handler missing.




Copyright © 2017 TJM