The GPU applications need to be updated for new AMD drivers

Message boards : Bug reports : The GPU applications need to be updated for new AMD drivers

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
RagnarokDel

Send message
Joined: 24 Nov 17
Posts: 1
Credit: 105,774,700
RAC: 0
Message 13672 - Posted: 19 Oct 2018, 14:20:56 UTC

AMD updated compute libraries at some point (cant remember which driver it was) in the past year and now enigma tasks are no longer compatibles. People shouldnt have to choose between being able to play new games properly and being able to contribute compute time in their off-hours. Thank you =)

Last drivers I can confirm working properly is 17.9.3. Those drivers are over a year old.
ID: 13672 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13673 - Posted: 19 Oct 2018, 14:40:05 UTC - in response to Message 13672.  

Yes, I'm having issues as well. Seems older cards are fine, but newer cards with newer drivers are not. I've tried re-installing Visual C++ Studio (2010 thru 2017) and all the other tricks mentioned in other threads, but still my Vega 64 card throws compute error in 3 seconds no matter what.

I will give 17.9.3 a try to see if it works.
ID: 13673 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13674 - Posted: 19 Oct 2018, 15:00:56 UTC

Can confirm that newer 18.9.3 and 18.10.1 drivers do not work with Enigma GPU app for my Vega 64. Rolling back to 17.9.3 works.

Didn't they remove the CAL driver or something from the drivers at some point? Is that the issue? Enigma GPU app needs the CAL driver for AMD? Just throwing ideas out there so someone can come up with a solution.
ID: 13674 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Amauri

Send message
Joined: 28 Feb 18
Posts: 2
Credit: 7,941,306
RAC: 0
Message 13676 - Posted: 21 Oct 2018, 20:02:29 UTC

Ubuntu 18.04, AMD 18.30 driver, also doesn't work. I can't roll back to a previous working version because it's not compatible with Ubuntu 18.04. Test WU's works fine...
ID: 13676 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile [AF>EDLS]GuL

Send message
Joined: 11 Sep 09
Posts: 1
Credit: 14,733,142
RAC: 0
Message 13681 - Posted: 4 Nov 2018, 18:46:21 UTC

Hello,
I can confirm that reverting to AMD driver 17.9.3 is the only working solution on a HD 7950. Updating Visual C++ from 2010 to 2017 has no effect.
ID: 13681 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Beyond
Avatar

Send message
Joined: 4 May 09
Posts: 2
Credit: 752,671,360
RAC: 82
Message 13687 - Posted: 2 Dec 2018, 20:20:18 UTC

I'm on Win7-64 and recently installed the 18.11.2 driver. It did not work. Did a clean install with the driver I had before (18.5.2) and it's working again. So 18.5.2 works at least in Win7-64.
ID: 13687 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13691 - Posted: 13 Dec 2018, 20:58:25 UTC

Can confirm that along with 17.9.3, the 18.5.2 version works on Win10-64 with Vega 64.
ID: 13691 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
kif kroker

Send message
Joined: 6 Feb 19
Posts: 1
Credit: 0
RAC: 0
Message 13706 - Posted: 6 Feb 2019, 14:14:37 UTC - in response to Message 13691.  
Last modified: 6 Feb 2019, 14:27:59 UTC

Adrenaline 19.1.1 drivers do not work, all WUs error out. when will this KNOWN issue be resolved? i am using ASUS rx560

Stderr output

<core_client_version>7.14.2</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code 195 (0xc3)</message>
<stderr_txt>
wrapper [26118 770 +dev#, opencl_ati_101]: starting (GPU #0)
07:16:05 (6364): wrapper: running enigma_opencl.exe (-d 0 -R -o results.txt 04trigr.cur 04unigr.cur 04ciphertext)
Found GPU 0: 'Baffin', Board name: 'Radeon RX 560 Series', Compute units: 14
app exit status: 0xc0000005
07:16:07 (6364): called boinc_finish

</stderr_txt>
]]>
ID: 13706 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
VietOZ

Send message
Joined: 23 May 18
Posts: 1
Credit: 780,397,738
RAC: 400
Message 13715 - Posted: 1 Mar 2019, 5:29:45 UTC

admin??
ID: 13715 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13716 - Posted: 3 Mar 2019, 19:00:00 UTC

Admins/devs seem to be absent here, but they sure love having us run their project. A little ridiculous if you ask me.

You want us to volunteer our resources but yet don't want to support or resources. LET"S GO ALREADY...FIX THIS SHIT!
ID: 13716 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13717 - Posted: 20 Mar 2019, 16:35:15 UTC

Wow. The admins/devs here are pretty ridiculous in ignoring the problems with the app.

What the hell does it take to get an answer/response from them?
ID: 13717 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
marmot

Send message
Joined: 21 Nov 15
Posts: 15
Credit: 13,075,271
RAC: 5
Message 13718 - Posted: 22 Mar 2019, 8:46:29 UTC - in response to Message 13687.  

I have an RX 550 (although performs like a WX 3100) and it errored out all the tasks on driver 19.3.1 on Windows 10 (Oct 2018) so came here looking for answers.
I was using 17.11.4 initially, because from decades of experience, keeping the card on a driver from 6 months after the cards' release is generally the best way to avoid issues with computation projects. But, 17.11.4 crashes regularly on SETI Lunatics WU's leading to SETI WU's sitting for hours doing nothing.


bluestang:
Can confirm that newer 18.9.3 and 18.10.1 drivers do not work with Enigma GPU app for my Vega 64. Rolling back to 17.9.3 works.

Beyond:
I'm on Win7-64 and recently installed the 18.11.2 driver. It did not work. Did a clean install with the driver I had before (18.5.2) and it's working again. So 18.5.2 works at least in Win7-64.



Decided to install backwards from 18.9.3 until I found a working driver.

18.9.1 - Enigma GPU WU fails in 8 seconds.
18.8.2 - Enigma GPU WU fails in 8 seconds.
18.7.1 -
22 Mar 2019, 8:37:43 UTC
Completed and validated
Enigma GPU v1.11 (opencl_ati_101)
715.33 seconds

So, seems like AMD updated the libraries in 18.8.2 (July-August 2018)


Version 18.7.1 notes claims speed increases for the RX and Vega families so maybe you'll see a boost over 18.5.2.
Worked on this for 3+ hours so not going backwards to do a performance test, today.
ID: 13718 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile horst1981
Avatar

Send message
Joined: 12 Nov 15
Posts: 4
Credit: 150,557,613
RAC: 1
Message 13719 - Posted: 23 Mar 2019, 7:00:31 UTC
Last modified: 23 Mar 2019, 7:01:30 UTC

Radeon VII,Adrenalin 19.3.3 drivers,win10, all WUs error out.

ID: 13719 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13724 - Posted: 1 Apr 2019, 23:41:04 UTC - in response to Message 13718.  

I have an RX 550 (although performs like a WX 3100) and it errored out all the tasks on driver 19.3.1 on Windows 10 (Oct 2018) so came here looking for answers.
I was using 17.11.4 initially, because from decades of experience, keeping the card on a driver from 6 months after the cards' release is generally the best way to avoid issues with computation projects. But, 17.11.4 crashes regularly on SETI Lunatics WU's leading to SETI WU's sitting for hours doing nothing.


bluestang:
Can confirm that newer 18.9.3 and 18.10.1 drivers do not work with Enigma GPU app for my Vega 64. Rolling back to 17.9.3 works.

Beyond:
I'm on Win7-64 and recently installed the 18.11.2 driver. It did not work. Did a clean install with the driver I had before (18.5.2) and it's working again. So 18.5.2 works at least in Win7-64.



Decided to install backwards from 18.9.3 until I found a working driver.

18.9.1 - Enigma GPU WU fails in 8 seconds.
18.8.2 - Enigma GPU WU fails in 8 seconds.
18.7.1 -
22 Mar 2019, 8:37:43 UTC
Completed and validated
Enigma GPU v1.11 (opencl_ati_101)
715.33 seconds

So, seems like AMD updated the libraries in 18.8.2 (July-August 2018)


Version 18.7.1 notes claims speed increases for the RX and Vega families so maybe you'll see a boost over 18.5.2.
Worked on this for 3+ hours so not going backwards to do a performance test, today.

Thanks for doing this. I'll run 18..5.2 for a few days then update to 18.7 1 and see if there is a difference on my Vega 64.
ID: 13724 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
marmot

Send message
Joined: 21 Nov 15
Posts: 15
Credit: 13,075,271
RAC: 5
Message 13731 - Posted: 11 Apr 2019, 6:40:30 UTC - in response to Message 13724.  


Thanks for doing this. I'll run 18..5.2 for a few days then update to 18.7 1 and see if there is a difference on my Vega 64.


NP.

Any results yet?

Being stuck at driver 18.7.1 didn't seem to cause any issues on 8 other projects until I tried to run multiple WU of Einstein@home Gamma-ray pulsar binary search #1 on GPUs v1.18 (ati) windows_x86_64 which crashes the driver with any more than 1 WU at once.

Enigma ran 8 WU at once, easily, with about a 20% boost in results/hour.
ID: 13731 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13733 - Posted: 11 Apr 2019, 17:09:10 UTC

18.7.1 seems to be about a 5 to 10% increase in PPD for me running 1 WU at a time on my Vega 64.

What are you running 8x at once on? When I tried more than 1 on my Vega, it was actually detrimental to times and less PPD. 2x WUs took more than double what 1 did.

I wish they would at least acknowledge something about driver issues in this damn place already!
ID: 13733 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
marmot

Send message
Joined: 21 Nov 15
Posts: 15
Credit: 13,075,271
RAC: 5
Message 13734 - Posted: 11 Apr 2019, 21:31:31 UTC - in response to Message 13733.  
Last modified: 11 Apr 2019, 21:38:18 UTC



What are you running 8x at once on?


A single slot RX 550 4GB (yes, 4, not 2GB) that runs at max clock at under 32W maximum power for PCIe slot (nice for upcoming summer months).

Estimated 250k credit/day from testing.

Was going to add 1 to each server with empty PCIe slots but the fan is 2mm away from the metal case instead of facing the interior so the CPU fans could pull the heat away. Like to smack the engineer that designed that slot position.
ID: 13734 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
bluestang

Send message
Joined: 23 May 18
Posts: 30
Credit: 277,162,269
RAC: 194
Message 13738 - Posted: 19 Apr 2019, 20:05:42 UTC

Bump so maybe one day or week or month or year or decade an Admin will see this and respond.

I don't understand why they feel the need to either ignore or be absent like this, not too professional.
ID: 13738 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile JStateson

Send message
Joined: 6 May 11
Posts: 3
Credit: 3,876,351
RAC: 0
Message 13739 - Posted: 20 Apr 2019, 18:37:31 UTC
Last modified: 20 Apr 2019, 18:38:32 UTC

No ATI apps work on ATI S9000. All failed
ID: 13739 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
marmot

Send message
Joined: 21 Nov 15
Posts: 15
Credit: 13,075,271
RAC: 5
Message 13740 - Posted: 21 Apr 2019, 0:42:53 UTC - in response to Message 13731.  
Last modified: 21 Apr 2019, 0:48:55 UTC


Being stuck at driver 18.7.1 didn't seem to cause any issues on 8 other projects


It does cause issues.

Had to install Adrenalin Oct 2018 to run multiple WU at Milkyway.
18.7.1 caused 40% invalid results but the ones that completed successfully completed 30% faster than single run WU...

Einstein can now run multi-WU on the RX 550; so the newer driver repaired that issue also.


Only solution, until Enigma fixes the library compatibility, is to downgrade/upgrade the driver when switching projects.

If anyone has a registry (or other) fix to get newest nVidia and AMD drivers to both have OpenCL allowed at once; send me a PM. Currently running CUDA on the nVidia and OpenCL on the AMD's.
ID: 13740 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
1 · 2 · Next

Message boards : Bug reports : The GPU applications need to be updated for new AMD drivers




Copyright © 2019 TJM