Progress % Varying Wildly from minute to minute...

Message boards : Bug reports : Progress % Varying Wildly from minute to minute...

To post messages, you must log in.

AuthorMessage
Profile Heather Clemenceau

Send message
Joined: 27 Mar 10
Posts: 2
Credit: 36,834
RAC: 0
Message 1550 - Posted: 29 Mar 2010, 18:10:07 UTC

Good Day,

I briefly searched for this topic, so apologies if it is redundant. I've noticed that, unlike other WUs for other projects, the percentage completion for Enigma varies wildly from minute to minute, often fluctuating from 99% complete back to 0% or some other percentage.

My current WU has been running for about 19 hours, and has just dropped down to 0% completing and back up to 76% completion within about 2 minutes.

What causes this fluctuation? And strangely enough, while running Enigma, no other projects are running, even though BOINC is set up to run all in succession - in other words, Enigma is monopolizing the GPU.

Thoughts?
ID: 1550 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
thinking_goose

Send message
Joined: 12 Nov 07
Posts: 116
Credit: 1,105,645
RAC: 0
Message 1553 - Posted: 31 Mar 2010, 11:47:17 UTC - in response to Message 1550.  

Hi Heather Clemenceau,

The phenomenon you have is common to most Enigma work units at present, I think. All my work units seem to be all over the place in terms of completion time, and vary a lot too. This fluctuation should have no effect on the actual completion of the work unit- they still run normally in every other sense. Your work unit times can be found here:

http://www.enigmaathome.net/results.php?hostid=25496

You can find this by opening your profile and viewing the computers added to your BOINC account.


ID: 1553 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Heather Clemenceau

Send message
Joined: 27 Mar 10
Posts: 2
Credit: 36,834
RAC: 0
Message 1554 - Posted: 31 Mar 2010, 16:24:43 UTC - in response to Message 1553.  

Thanks Greg, I guess it's quite apropos to be running an enigmatic app named "enigma......"
ID: 1554 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Phil
Avatar

Send message
Joined: 20 Jul 08
Posts: 4
Credit: 719,279
RAC: 31
Message 1561 - Posted: 16 Apr 2010, 14:49:49 UTC - in response to Message 1550.  



What causes this fluctuation? And strangely enough, while running Enigma, no other projects are running, even though BOINC is set up to run all in succession - in other words, Enigma is monopolizing the GPU.

Thoughts?


Enigma runs a BOINC wrapper which is an interface program between BOINC Manager and a 3rd-party program not written to run with BOINC.
That mean that the %done and Time Remaining indications dont do anything at all unless the project owner can can fix it in some way.
Enigma worked fine with the "M4" workunits but it seems the present jobs dont do anything that BOINC understands at all!
ID: 1561 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,147,457
RAC: 393,702
Message 1562 - Posted: 19 Apr 2010, 12:07:50 UTC

Current version of the wrapper is slightly broken, as it was not designed to run M3 workunits with multiple restarts per workunit. There is no easy way to fix that, I'll just try to avoid such batches of workunits in future.

M4 Project homepage
M4 Project wiki
ID: 1562 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Bradleigh Stockwell

Send message
Joined: 10 Apr 10
Posts: 1
Credit: 1,769
RAC: 0
Message 1570 - Posted: 19 Apr 2010, 23:06:08 UTC - in response to Message 1550.  

Hello - I added Enigma to my projects and, like you, found it was monopolizing my BOINC projects to an astonishing degree. When I considered canceling my Enigma account, I was asked if I wanted to delete the project. Curiously, it presented me with a string of Asian - Chinese? - characters. Well, that settled it. I'm outta here.
ID: 1570 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 71,147,457
RAC: 393,702
Message 1667 - Posted: 3 Jul 2010, 12:31:09 UTC

After running several tests, it turns out that all versions of the wrapper are slightly bugged - progress report does not work correctly with majority of the M3 workunits. I'll patch the Linux wrapper first and then I'll port the changes to Windows.


M4 Project homepage
M4 Project wiki
ID: 1667 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Bug reports : Progress % Varying Wildly from minute to minute...




Copyright © 2017 TJM