Error Message: BOINC 6.12.4

Message boards : Number crunching : Error Message: BOINC 6.12.4

To post messages, you must log in.

AuthorMessage
Profile mdoerner
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 30 Jul 08
Posts: 202
Credit: 6,998,388
RAC: 0
Message 1816 - Posted: 7 Nov 2010, 0:02:09 UTC

Hiya TJM,

You know I'm running an optimized app. The current version of BOINC that I'm running has a notice in the "Notice" tab.


Notice from BOINC
Message from Enigma@Home: Your app_info.xml file doesn't have a usable version of Enigma 0.76b.

Interesting. Do I need to re-compile the optimized app, or is it just complaining about the xml file? Thanks.

Mike D

ID: 1816 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 69,828,578
RAC: 386,226
Message 1817 - Posted: 7 Nov 2010, 13:01:34 UTC

Definitely problem with the XML file, which one is it ?


M4 Project homepage
M4 Project wiki
ID: 1817 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile mdoerner
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 30 Jul 08
Posts: 202
Credit: 6,998,388
RAC: 0
Message 1819 - Posted: 10 Nov 2010, 22:26:29 UTC - in response to Message 1817.  

Not sure. That's all I got out of the error message.

Mike D
ID: 1819 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile mdoerner
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 30 Jul 08
Posts: 202
Credit: 6,998,388
RAC: 0
Message 1830 - Posted: 13 Nov 2010, 12:30:19 UTC

Never mind TJM, BOINC 6.12.6 doesn't have this error message.....

Mike D
ID: 1830 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 69,828,578
RAC: 386,226
Message 1831 - Posted: 13 Nov 2010, 16:14:03 UTC

That's weird, it worked for me - at least on Windows XP. On Linux doesn't work at all, not a single 6.12 build worked for me.

M4 Project homepage
M4 Project wiki
ID: 1831 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile mdoerner
Volunteer developer
Volunteer tester
Avatar

Send message
Joined: 30 Jul 08
Posts: 202
Credit: 6,998,388
RAC: 0
Message 1835 - Posted: 14 Nov 2010, 4:08:51 UTC - in response to Message 1831.  
Last modified: 14 Nov 2010, 4:10:46 UTC

I had to add libopenssl0_9_8 via YAST in OpenSUSE 11.3 to get anything beyond BOINC 6.11.4 to work, but once that was installed, been a piece of cake......

Mike D
ID: 1835 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 69,828,578
RAC: 386,226
Message 1843 - Posted: 17 Nov 2010, 9:02:18 UTC - in response to Message 1835.  

Here the problem is a lot worse, core client complains about libs which I have installed and they're in correct paths.
I gave up on 64 bit version as it looks hopeless on my system, I tried 32bit and got it to the point where it asked for GLIBC version which I have installed (comes with the base system I think), I got stuck there.
Then I tried on Ubuntu and everything works fine.

6.10.58 is the last one that works for me on Etch/Lenny.
M4 Project homepage
M4 Project wiki
ID: 1843 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
quel

Send message
Joined: 19 May 09
Posts: 34
Credit: 32,879,565
RAC: 1,838
Message 1848 - Posted: 20 Nov 2010, 6:04:59 UTC

If the problems are with the boinc enigma app with an optimized version then someone isn't compiling -static -static-libgcc before handling out binaries for the *nix crowd.

6.10.58 isn't even available for Lenny via backports or any route other than manually building the deb and hacking out the udev stuff *or* installing straight from the non-packed installers upstream. Also, isn't 6.10.58 the latest stable release upstream anyway? Unless you're looking for the *nix CUDA fixes newer than 6.10.58 why try something labeled experimental?

Is the ssl dependency part of the boinc software or the enigma app? AFAIK ssl has been required for boinc itself for a long time - well before 6.10.58.
ID: 1848 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 69,828,578
RAC: 386,226
Message 1849 - Posted: 20 Nov 2010, 11:29:32 UTC - in response to Message 1848.  
Last modified: 20 Nov 2010, 11:30:18 UTC

The app itself runs fine, just the boinc core client doesn't.
I believe that the enigma executable itself is so simple, it doesn't require any external libraries.
M4 Project homepage
M4 Project wiki
ID: 1849 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
quel

Send message
Joined: 19 May 09
Posts: 34
Credit: 32,879,565
RAC: 1,838
Message 1850 - Posted: 23 Nov 2010, 9:15:31 UTC - in response to Message 1849.  

enigma2_0.76_i686-pc-linux-gnu:
not a dynamic executable
wrapper_5.22_i686-pc-linux-gnu:
not a dynamic executable

You are correct - no external dependencies or at least statically linked.

"6.10.58 is the last one that works for me on Etch/Lenny."

Eh that's the latest stable release - beta and alpha quality releases are just that. Wait for the next stable release?
ID: 1850 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Number crunching : Error Message: BOINC 6.12.4




Copyright © 2017 TJM