Error when trying to download a new task

Message boards : Bug reports : Error when trying to download a new task

To post messages, you must log in.

AuthorMessage
Xtremerandom

Send message
Joined: 2 Jan 11
Posts: 3
Credit: 91,980
RAC: 0
Message 1888 - Posted: 4 Jan 2011, 16:18:35 UTC

Whenever I report completed tasks and request new ones, the server always tries to send a single one to me, but it always throws out the same error:

Requesting new tasks for CPU
Scheduler request completed: got 1 new tasks
Message from server: Resent lost task wrmkx100_0_13696285_67_3
[error] State file error: missing file m3_wrmkx100_6
[error] State file error: missing input file m3_wrmkx100_6
[error] Can't handle task wrmkx100_0_13696285_67 in scheduler reply
[error] State file error: missing task wrmkx100_0_13696285_67
[error] Can't handle task wrmkx100_0_13696285_67_3 in scheduler reply

How do I get these missing files?

Help much appreciated :)
ID: 1888 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
elgordodude

Send message
Joined: 3 Jun 10
Posts: 9
Credit: 1,289,107
RAC: 0
Message 1891 - Posted: 5 Jan 2011, 1:24:58 UTC - in response to Message 1888.  

It looks like the server is telling you you can't. Have you tried detaching and reattaching? Just to get it out of the cache, and your messages.
ID: 1891 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Xtremerandom

Send message
Joined: 2 Jan 11
Posts: 3
Credit: 91,980
RAC: 0
Message 1896 - Posted: 5 Jan 2011, 8:50:06 UTC

Oh, I thought it meant I can't because it can't download the file. I'll try that - resetting the project didn't work though.
ID: 1896 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Xtremerandom

Send message
Joined: 2 Jan 11
Posts: 3
Credit: 91,980
RAC: 0
Message 1897 - Posted: 5 Jan 2011, 10:22:29 UTC

Solved the problem! Thanks :)
ID: 1897 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 69,890,797
RAC: 386,413
Message 1910 - Posted: 17 Jan 2011, 12:17:29 UTC

Did you solve that by resetting the project or detaching/reattaching ?
That was a weird bug because wrmkx-100 workunits are not on active workunits list anymore, and in fact, I can't find any of them (active) in the DB. They were disabled some time ago.

M4 Project homepage
M4 Project wiki
ID: 1910 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Bug reports : Error when trying to download a new task




Copyright © 2017 TJM