Enigma "computation error"

Message boards : Bug reports : Enigma "computation error"

To post messages, you must log in.

AuthorMessage
'Captain' Kirk DeHaan

Send message
Joined: 29 Apr 11
Posts: 1
Credit: 539,316
RAC: 1
Message 3359 - Posted: 21 Mar 2015, 1:37:49 UTC
Last modified: 21 Mar 2015, 1:39:16 UTC

I have a Galaxy 5 running the Lollipop OS. I am attached to both seti and enigma. The Enigma app, 0.76b, shows, under tasks, a computation error after downloading and attempting to run a file. Shortly after this they all disappear, it downloads another batch of files and fails again on the computation. Boinc is 7.4.41.

Any pointers? I know there is an issue with the seti module. Is there a similar issue with this OS and enigma?

Kirk - N6SXR
ID: 3359 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dr Who Fan

Send message
Joined: 6 May 11
Posts: 49
Credit: 205,695
RAC: 15
Message 3361 - Posted: 21 Mar 2015, 16:17:51 UTC - in response to Message 3359.  

Like the majority of the other BOINC projects, Enigma does not currently support Android V5/Lollipop "PIE" executables.

To see which projects support Android V5 goto http://wuprop.boinc-af.org/results/delai.py.
Use the menu options on the left side of screen to narrow down the search.

ID: 3361 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
thinking_goose

Send message
Joined: 12 Nov 07
Posts: 116
Credit: 1,105,400
RAC: 0
Message 3362 - Posted: 21 Mar 2015, 19:20:52 UTC

Is there a way to try a different BOINC version? I'm running NativeBOINC here. I don't know what version of Android it is though, but Enigma works fine on that.
ID: 3362 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dr Who Fan

Send message
Joined: 6 May 11
Posts: 49
Credit: 205,695
RAC: 15
Message 3363 - Posted: 21 Mar 2015, 21:47:18 UTC - in response to Message 3362.  
Last modified: 21 Mar 2015, 21:53:45 UTC

Another version of BOINC will NOT help.

thinking_goose, Your Android device is running Android 3.0.8-perf, also known as Android Ice Cream Sandwich/Android V4.0

I have NativeBOINC running on my Google/Nexus7 tablet to crunch MilkyWay@home since they do not have a native ARM version of their app. That is part of the reason I have not installed Lollipop on it.

NativeBOINC is now considered outdated, no longer supported by the original developer and only runs on PRE V5 Android OS equipped ARM processors.

ID: 3363 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Account Deleted

Send message
Joined: 1 Sep 14
Posts: 11
Credit: 1,123,799
RAC: 0
Message 3646 - Posted: 2 Nov 2015, 18:24:19 UTC - in response to Message 3359.  

Confirming the same issue on OnePlus 2 running OxygenOS 2.1 (Lollipop 5.1). I thought I screwed something up on my end. Is Enigma going to support Android 5+ anytime soon?
ID: 3646 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile rebirther
Avatar

Send message
Joined: 10 Sep 07
Posts: 18
Credit: 2,832,564
RAC: 0
Message 3783 - Posted: 20 Nov 2015, 18:47:52 UTC

Can we have new apps to support Android 5+, I got a new tab and cant run BOINC anymore, see here
http://boinc.berkeley.edu/trac/wiki/AndroidBuildApp#Position-independentexecutablesPIE
ID: 3783 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile rebirther
Avatar

Send message
Joined: 10 Sep 07
Posts: 18
Credit: 2,832,564
RAC: 0
Message 3851 - Posted: 16 Feb 2016, 15:37:24 UTC - in response to Message 3783.  

Can we have new apps to support Android 5+, I got a new tab and cant run BOINC anymore, see here
http://boinc.berkeley.edu/trac/wiki/AndroidBuildApp#Position-independentexecutablesPIE


Any progress in making the app android 5+ compatible?
ID: 3851 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Jonathan Jacobs

Send message
Joined: 31 Mar 12
Posts: 1
Credit: 95,671
RAC: 207
Message 3885 - Posted: 10 Mar 2016, 4:33:16 UTC

I had Windows 7 then upgraded to 10 and I still have not been able to run Enigma, just get computational error messages.
ID: 3885 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
WhiteWulfe
Avatar

Send message
Joined: 4 May 16
Posts: 1
Credit: 63,046
RAC: 24
Message 3987 - Posted: 2 Jul 2016, 5:17:58 UTC

Bumping the thread, as I'm curious as to when Android versions 5.0 and higher will be supported. My oldest device (Samsung Galaxy S3) running 4.4.1 seems to be able to do tasks without issue (although it's only a few percent in), but my HTC One M8 (running Android 6.0) gets computation errors immediately.
ID: 3987 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
lanbrown

Send message
Joined: 22 Aug 11
Posts: 63
Credit: 119,350,994
RAC: 2,834
Message 3988 - Posted: 3 Jul 2016, 3:26:05 UTC - in response to Message 3987.  

Probably never since there is about (estimated) 15 months of work left. The project owner is barely around.
ID: 3988 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
marmot

Send message
Joined: 21 Nov 15
Posts: 3
Credit: 170,468
RAC: 0
Message 4000 - Posted: 14 Jul 2016, 23:31:16 UTC - in response to Message 3361.  
Last modified: 14 Jul 2016, 23:34:21 UTC

Like the majority of the other BOINC projects, Enigma does not currently support Android V5/Lollipop "PIE" executables.

To see which projects support Android V5 goto http://wuprop.boinc-af.org/results/delai.py.
Use the menu options on the left side of screen to narrow down the search.



I tried this for Citizen's Science Grid but the list only returns device names and not OS versions
http://wuprop.boinc-af.org/results/arm.py?projet=Citizen+Science+Grid&application=SubsetSum%40Home+Sum+Calculator
so unless you want to look up every device in the list, by hand, to see if any are Android 5+, then it's not a extremely useful technique to see if Android 5 is supported.
Although, we know for sure all devices running Enigma 0.76 have to be Android version prior to 5 so the names in this list, if found in other lists, are likely not Android 5
http://wuprop.boinc-af.org/results/arm.py?projet=Enigma%40Home&application=Enigma+0.76b

Currently, I'm just trying adding each project and trying some WU's and checking message boards if computation errors occur.
ID: 4000 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Marius

Send message
Joined: 5 Sep 13
Posts: 2
Credit: 2,617,114
RAC: 526
Message 4229 - Posted: 10 Jan 2017, 21:42:06 UTC

Why Enigma still doesn't support Android 6,0?
ID: 4229 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Rollo1996

Send message
Joined: 14 May 13
Posts: 24
Credit: 2,068,948
RAC: 0
Message 4230 - Posted: 11 Jan 2017, 8:00:07 UTC
Last modified: 11 Jan 2017, 8:00:24 UTC

same here, my Huawei P8 (android 6.0) has this same issue. hope it will be fixed somehow.
ID: 4230 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Danny

Send message
Joined: 30 Apr 15
Posts: 1
Credit: 287,399
RAC: 0
Message 4239 - Posted: 22 Jan 2017, 9:32:24 UTC - in response to Message 3361.  

it doesn't work on 7.0 either... none of my enigma have work from lollipop through to Neuget.. but i keep on trying it and I have probably had a million of these computations errors... but the weird thing is though.. I once had a display version of a galaxy s6 edge (which has the processors but won't work as a phone) I flashed 6.0 on to it and that run enigma projects with no dramas... but that was the only phone it has actually ever worked on.
ID: 4239 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Bernard

Send message
Joined: 2 May 15
Posts: 10
Credit: 9,026,641
RAC: 12
Message 4240 - Posted: 22 Jan 2017, 11:59:40 UTC
Last modified: 22 Jan 2017, 11:59:57 UTC

Hi, in general enigma@home can't run on Android 5+ without changes. The native application has to be compiled with PIE flags.
non-PIE linker support removed. Android now requires all dynamically linked executables to support PIE (position-independent executables). This enhances Android’s address space layout randomization (ASLR) implementation.
Source: https://source.android.com/security/enhancements/enhancements50.html

The admin may wont fix it anymore. I don't know and I cant help without permissions. The project may end in the begin of September 2017 http://www.enigmaathome.net/forum_thread.php?id=795.

May you should use your Android for other scientific applications like https://einsteinathome.org as I do. Greetings.
ID: 4240 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
DJX
Avatar

Send message
Joined: 14 Dec 15
Posts: 2
Credit: 1,031,782
RAC: 67
Message 4274 - Posted: 17 Feb 2017, 14:12:26 UTC

Same problem on my SM-928T with Android 6.0.1.
Would be really nice to have Enigma working.
ID: 4274 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Yavanius
Avatar

Send message
Joined: 13 May 15
Posts: 5
Credit: 192,442
RAC: 1,873
Message 4276 - Posted: 19 Feb 2017, 6:16:58 UTC

Actually, I have a few devices that are upgraded to 5 (via official channels) that I have no issues with. My Tab S2 that went to 6 is a different issue.

Sofar, I know Einstein, SETI, and POGS Skynet all seem to run across the different versions without issue (that I personally observed). WU Prop does although it's NCI.

There might be other projects, but I haven't looked into every one like Collatz.

Engima isn't a big project. Technically the original goals of the project were met, but additional messages were added since there was still interest in the project.

You could always learn to code and make apps that are compatible with v5 and beyond. It's been done before. ;)
ID: 4276 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote

Message boards : Bug reports : Enigma "computation error"




Copyright © 2017 TJM