A GPU version of Enigma software

Message boards : Number crunching : A GPU version of Enigma software

To post messages, you must log in.

Previous · 1 . . . 3 · 4 · 5 · 6 · 7 · 8 · 9 . . . 11 · Next

AuthorMessage
Empie

Send message
Joined: 5 Mar 10
Posts: 12
Credit: 31,477,099
RAC: 8,694
Message 5369 - Posted: 4 Jul 2017, 15:37:29 UTC

Today had a Enigma CUDA wu which ran 31 secs but completed succesfully. Doesn't seem to be right. See: http://www.enigmaathome.net/result.php?resultid=275178503
ID: 5369 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,472,335
RAC: 388,629
Message 5370 - Posted: 4 Jul 2017, 15:42:31 UTC - in response to Message 5369.  
Last modified: 4 Jul 2017, 15:45:46 UTC

It was restarted at some point. The app saves it's state on exit but since it does not report it to the BOINC client, it thinks that it was a fresh start and reports only the fraction of runtime, that's required to finish the task.
M4 Project homepage
M4 Project wiki
ID: 5370 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Empie

Send message
Joined: 5 Mar 10
Posts: 12
Credit: 31,477,099
RAC: 8,694
Message 5371 - Posted: 4 Jul 2017, 15:49:10 UTC

Clear, thanks for the reply.
ID: 5371 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex VE3NEA

Send message
Joined: 22 Oct 16
Posts: 36
Credit: 128,745
RAC: 0
Message 5373 - Posted: 5 Jul 2017, 16:29:32 UTC

A small bug has been fixed in enigma-cuda. The bug has not affected anything so far but might cause a problem eventually. Please download the updated executables.
ID: 5373 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
10esseeTony

Send message
Joined: 4 Nov 14
Posts: 3
Credit: 25,350,694
RAC: 11,314
Message 5374 - Posted: 5 Jul 2017, 18:32:04 UTC - in response to Message 5373.  

Uhm...how do you download the updated executables? I use the Windows BOINC Manager, I don't recall seeing an option of that sort, other than removing the project and reinstalling it.
ID: 5374 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex VE3NEA

Send message
Joined: 22 Oct 16
Posts: 36
Credit: 128,745
RAC: 0
Message 5375 - Posted: 5 Jul 2017, 18:35:32 UTC - in response to Message 5374.  

I guess TJM will download them and put them on his server, then your client will pick them up automatically
ID: 5375 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,472,335
RAC: 388,629
Message 5376 - Posted: 5 Jul 2017, 18:52:05 UTC - in response to Message 5375.  
Last modified: 5 Jul 2017, 18:52:38 UTC

Yep, but since it is not that critical, I'll do it later today or tomorrow morning.
At this moment I added single walk of ALQFI (M3/Heer settings, ukw B) to check if it'll pass through the server. If it does I'll switch it to full batch.
M4 Project homepage
M4 Project wiki
ID: 5376 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
oh2hyt

Send message
Joined: 14 Jul 09
Posts: 52
Credit: 185,964,652
RAC: 978,582
Message 5377 - Posted: 5 Jul 2017, 21:50:55 UTC - in response to Message 5373.  

A small bug has been fixed in enigma-cuda. The bug has not affected anything so far but might cause a problem eventually. Please download the updated executables.

Thanks informing here. Updated and everything works fine.
ID: 5377 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Ross*

Send message
Joined: 25 Nov 13
Posts: 4
Credit: 195,813,123
RAC: 39
Message 5378 - Posted: 6 Jul 2017, 0:18:48 UTC - in response to Message 5377.  

Hi
How can I get GPU tasks?
I notice that most of the top computers are using "anonymous" setup. I can't find any files or apps to use.
I have 6 1080s waiting to go but no tasks.
On one box with a titan Z with a app config to use all GPUs the messages have gone from "no tasks available" to "got 0 tasks"
The server appears to have tasks to be sent and other computers are getting them.
Cheers
Ross
ID: 5378 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,472,335
RAC: 388,629
Message 5379 - Posted: 6 Jul 2017, 6:02:11 UTC - in response to Message 5378.  

You have to allow beta work in project preferences on the website.
M4 Project homepage
M4 Project wiki
ID: 5379 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Ross*

Send message
Joined: 25 Nov 13
Posts: 4
Credit: 195,813,123
RAC: 39
Message 5385 - Posted: 6 Jul 2017, 8:30:24 UTC - in response to Message 5379.  

Hi
thanks for that.
the titan Z box is working on both GPUs,
BUT 2 other boxes are all failing in 3 seconds.
what do I have to do to get them to go?
Cheers
Ross*
ID: 5385 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Ross*

Send message
Joined: 25 Nov 13
Posts: 4
Credit: 195,813,123
RAC: 39
Message 5526 - Posted: 6 Jul 2017, 11:07:42 UTC - in response to Message 5385.  

Hi
thanks for that.
the titan Z box is working on both GPUs,
BUT 2 other boxes are all failing in 3 seconds.
what do I have to do to get them to go?
Cheers
Ross*

further to:
<core_client_version>7.6.33</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code 195 (0xc3)
</message>
<stderr_txt>
wrapper [26118 718 + noargs]: starting
22:56:26 (2008): wrapper: running enigma_cuda.exe (-R -o results.txt 04trigr.cur 04unigr.cur 04ciphertext)
app exit status: 0xc000007b
22:56:27 (2008): called boinc_finish

</stderr_txt>
]]>
box Venus all tasks error out in 3 secounds , can't work out why?
Cheers
Ross*
ID: 5526 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,472,335
RAC: 388,629
Message 5531 - Posted: 6 Jul 2017, 11:21:24 UTC - in response to Message 5526.  

Do you have Visual Studio 2015 c++ redistributable package installed ?
M4 Project homepage
M4 Project wiki
ID: 5531 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
matszpk
Project tester
Volunteer developer
Volunteer tester

Send message
Joined: 20 May 11
Posts: 8
Credit: 6,977,690
RAC: 92,894
Message 5771 - Posted: 6 Jul 2017, 18:36:36 UTC

Hi. I wrote Enigma for OpenCL (AMD/ATI graphics card) based on work of Alex VE3NEA.
Source code available at https://github.com/matszpk/enigma-cuda/tree/opencl.
Binaries at https://github.com/matszpk/enigma-cuda/tree/opencl/enigma-opencl/bin.
This is still very early version only for testing.
ID: 5771 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
mmonnin

Send message
Joined: 2 Jul 16
Posts: 22
Credit: 11,951,945
RAC: 0
Message 5772 - Posted: 6 Jul 2017, 19:37:31 UTC - in response to Message 5376.  

Yep, but since it is not that critical, I'll do it later today or tomorrow morning.
At this moment I added single walk of ALQFI (M3/Heer settings, ukw B) to check if it'll pass through the server. If it does I'll switch it to full batch.


I have had some of these complete. Pretty quick.
ID: 5772 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Ross*

Send message
Joined: 25 Nov 13
Posts: 4
Credit: 195,813,123
RAC: 39
Message 5773 - Posted: 7 Jul 2017, 0:10:29 UTC - in response to Message 5531.  

Hi
yes it solves all my problems . both GPUs running.
Thanks for the prompt replies, much appreciated.
Cheers
Ross*

ID: 5773 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,472,335
RAC: 388,629
Message 5780 - Posted: 7 Jul 2017, 8:57:15 UTC - in response to Message 5772.  

Yep, but since it is not that critical, I'll do it later today or tomorrow morning.
At this moment I added single walk of ALQFI (M3/Heer settings, ukw B) to check if it'll pass through the server. If it does I'll switch it to full batch.


I have had some of these complete. Pretty quick.


I used short workunits in two batches for testing purposes, I'll avoid that in the future because it slows down processing a bit and also causes unnecessary stress on the server.
M4 Project homepage
M4 Project wiki
ID: 5780 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
NN

Send message
Joined: 29 May 10
Posts: 5
Credit: 2,186,425
RAC: 1,388
Message 5782 - Posted: 7 Jul 2017, 10:20:47 UTC
Last modified: 7 Jul 2017, 10:35:40 UTC

Hello TJM,

a 64bit-task failed immediately on my PC, I think because no job_...xml was transmitted. Or is it the same for both versions ?

With greetings

NN
ID: 5782 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
mmonnin

Send message
Joined: 2 Jul 16
Posts: 22
Credit: 11,951,945
RAC: 0
Message 5783 - Posted: 7 Jul 2017, 11:58:24 UTC - in response to Message 5780.  

Yep, but since it is not that critical, I'll do it later today or tomorrow morning.
At this moment I added single walk of ALQFI (M3/Heer settings, ukw B) to check if it'll pass through the server. If it does I'll switch it to full batch.


I have had some of these complete. Pretty quick.


I used short workunits in two batches for testing purposes, I'll avoid that in the future because it slows down processing a bit and also causes unnecessary stress on the server.


They were fine in small batches. I wish all GPU project admins see the small WU size issue.
ID: 5783 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5815 - Posted: 9 Jul 2017, 7:05:13 UTC - in response to Message 5780.  

Hi, before some days I found info about Enigma on GPU. I have 2x 1080Ti on my rig but when I install Visual Studio 2015 c++ redistributable package (32 and 64 bit too), add rows do cc and app config and enable running beta and GPU in Enigma settings, all my workunits end after first few seconds of computig with error.
You can look on it and help me how solve it?
http://www.enigmaathome.net/results.php?userid=145166

Errors is same on all units, firs was on Enigma Cuda v1.06 (cuda_fermi) windows_x86_64, last was on Enigma Cuda v1.07 (cuda_fermi) windows_x86_64.

Error: 195 (0x000000C3) EXIT_CHILD_FAILED

I add to cc config:
<exclude_gpu>
<url>http://www.enigmaathome.net/</url>
<device_num>1</device_num>
</exclude_gpu>

to exclude computing on my second GPU

and add to app config:
<app_config>
<app>
<name>enigma_cuda</name>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>1</cpu_usage>
</gpu_versions>
</app>
</app_config>

Still have problems and I cannot compute Enigma on my GPU.

<core_client_version>7.6.33</core_client_version>
<![CDATA[
<message>
(unknown error) - exit code 195 (0xc3)
</message>
<stderr_txt>
wrapper [26118 718 + noargs]: starting
13:29:02 (8472): wrapper: running enigma_cuda.exe (-R -o results.txt 04trigr.cur 04unigr.cur 04ciphertext)
app exit status: 0xc000001d
13:29:05 (8472): called boinc_finish

</stderr_txt>
]]>

Can someone help me please?
ID: 5815 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Previous · 1 . . . 3 · 4 · 5 · 6 · 7 · 8 · 9 . . . 11 · Next

Message boards : Number crunching : A GPU version of Enigma software




Copyright © 2017 TJM