A GPU version of Enigma software

Message boards : Number crunching : A GPU version of Enigma software

To post messages, you must log in.

Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 11 · Next

AuthorMessage
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5817 - Posted: 9 Jul 2017, 7:13:23 UTC - in response to Message 5815.  

And I use last nvidia drivers.
ID: 5817 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,402,822
RAC: 388,121
Message 5818 - Posted: 9 Jul 2017, 7:24:54 UTC - in response to Message 5815.  
Last modified: 9 Jul 2017, 7:26:17 UTC

App info like yours will not work because in it's current state the app does not run on devices other than #0.
It runs via wrapper which removes --device option when passed from BOINC manager, because the app itself does not understand that and will refuse to run.

The "195" error is a separate problem, it means the wrapper is unable to run the main program, usually because it exits with error on startup. Find the main executable (enigma_cuda_1.07.....exe) inside the project folder and try to run it via command line, perhaps it'll show something about the reason why it's refusing to run.
M4 Project homepage
M4 Project wiki
ID: 5818 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5820 - Posted: 10 Jul 2017, 15:19:47 UTC - in response to Message 5818.  
Last modified: 10 Jul 2017, 15:49:24 UTC

Hi, in cmd I can run app and it say: tree file names required and quit. Can you send me what I may exact try to run to check if it works?
My PC have two 1080Ti´s in one PC, can it be this problem nor not?
ID: 5820 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,402,822
RAC: 388,121
Message 5822 - Posted: 11 Jul 2017, 7:28:11 UTC - in response to Message 5820.  

ID: 5822 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5824 - Posted: 11 Jul 2017, 14:52:13 UTC - in response to Message 5822.  

Hi, after run bat file(s) it found my gpu 1080Ti w comp. capab 6.1 and after that boinc-cuda.exe crash without any errors and at cmd is shown only pause text. Any other ideas please? Want to run Enigma on my fast GPU ...
ID: 5824 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5844 - Posted: 14 Jul 2017, 12:32:15 UTC - in response to Message 5822.  

Any other idea what can be bad?
ID: 5844 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex VE3NEA

Send message
Joined: 22 Oct 16
Posts: 36
Credit: 128,745
RAC: 0
Message 5845 - Posted: 14 Jul 2017, 12:44:50 UTC - in response to Message 5844.  

@Dzordzik, please check the code returned by the program. Add these lines to the bat file after the line that runs the enigma-cuda.exe:

@echo.
@echo Return code = %errorlevel%
pause

The success code is 0, other codes are errors.
ID: 5845 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5846 - Posted: 14 Jul 2017, 18:46:09 UTC - in response to Message 5845.  

After run m4 bat Enigma app crash, in cmd return code -1073741795

My m4 bat looks like this:
enigma-cuda.exe -M M4 -f b:g438:AA:AAAA -t b:g438:ZZ:ZZZZ -n 1 -a -g 013 00trigr.u534 00ugr.u534 m4_test72_31
@echo.
@echo Return code = %errorlevel%
pause

Is it right?

Have installed VS C++ redistr. 2010, 12, 13 and 15, x86 and 64b too. My OS Win7 64bit any my GPUs was 2x GTX 1080Ti FE that was stable and wo problems at other projects including GPUGrid or Primegrid.
ID: 5846 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5847 - Posted: 14 Jul 2017, 18:48:23 UTC - in response to Message 5846.  

Cards wo SLI for info but it doesn´t matter I think.
ID: 5847 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex VE3NEA

Send message
Joined: 22 Oct 16
Posts: 36
Credit: 128,745
RAC: 0
Message 5848 - Posted: 14 Jul 2017, 18:53:51 UTC

ID: 5848 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Dzordzik

Send message
Joined: 11 Mar 17
Posts: 13
Credit: 46,669,919
RAC: 785,529
Message 5849 - Posted: 15 Jul 2017, 6:25:18 UTC - in response to Message 5848.  

I´m not programmer but here is something about AVX instructions, can be this problem because my old Xeon not support AVX? My CPU is Dual Xeon X5950.
ID: 5849 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Alex VE3NEA

Send message
Joined: 22 Oct 16
Posts: 36
Credit: 128,745
RAC: 0
Message 5851 - Posted: 15 Jul 2017, 13:05:56 UTC

A new build of enigma-cuda.exe is available. This build:

1) does not use AVX or SSE instructions (the speed is the same);
2) has a new command line option, -d <cuda device number> (0-based indexing).

The source and new binaries are here: https://github.com/VE3NEA/enigma-cuda
ID: 5851 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Dave GPU

Send message
Joined: 3 Dec 14
Posts: 9
Credit: 451,589,695
RAC: 6,648,656
Message 5852 - Posted: 15 Jul 2017, 15:35:37 UTC - in response to Message 5851.  
Last modified: 15 Jul 2017, 15:36:30 UTC

A new build of enigma-cuda.exe is available. This build:

1) does not use AVX or SSE instructions (the speed is the same);
2) has a new command line option, -d <cuda device number> (0-based indexing).

The source and new binaries are here: https://github.com/VE3NEA/enigma-cuda



Will the new build of enigma-cuda.exe, be implemented on the enigma server, or is there a cheat sheet for dummies ?
ID: 5852 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,402,822
RAC: 388,121
Message 5853 - Posted: 15 Jul 2017, 16:20:26 UTC - in response to Message 5852.  
Last modified: 15 Jul 2017, 16:21:47 UTC


Will the new build of enigma-cuda.exe, be implemented on the enigma server, or is there a cheat sheet for dummies ?


I'll update the apps on the server later today. GPU workunits generator will be stopped for around ~1h right before update.
M4 Project homepage
M4 Project wiki
ID: 5853 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Dave GPU

Send message
Joined: 3 Dec 14
Posts: 9
Credit: 451,589,695
RAC: 6,648,656
Message 5854 - Posted: 15 Jul 2017, 16:44:15 UTC - in response to Message 5853.  


Will the new build of enigma-cuda.exe, be implemented on the enigma server, or is there a cheat sheet for dummies ?


I'll update the apps on the server later today. GPU workunits generator will be stopped for around ~1h right before update.



Thanks for update.
ID: 5854 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,402,822
RAC: 388,121
Message 5856 - Posted: 15 Jul 2017, 23:23:44 UTC - in response to Message 5854.  
Last modified: 15 Jul 2017, 23:29:52 UTC

App version updated to 1.08. It ships with new wrapper that translates --device passed by BOINC manager to -d
Seems to be working, at least with -d 0.

Note for app_info users: 1.08 wrapper won't work combined with previous versions of the app. New app will still work with 1.07 and older wrappers, but won't support --device / -d
M4 Project homepage
M4 Project wiki
ID: 5856 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Dave GPU

Send message
Joined: 3 Dec 14
Posts: 9
Credit: 451,589,695
RAC: 6,648,656
Message 5858 - Posted: 16 Jul 2017, 12:35:18 UTC

Update to 1.08 is working well, 2 old Xeon rigs & 1 Dual-Core Processor can run GPU WU. Thanks.
ID: 5858 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
JugNut

Send message
Joined: 16 Mar 13
Posts: 24
Credit: 104,441,241
RAC: 454,994
Message 5859 - Posted: 16 Jul 2017, 14:04:54 UTC - in response to Message 5858.  
Last modified: 16 Jul 2017, 14:08:13 UTC

For me the GPU app still only works on one GPU, allowing two WU's to run only runs them both on the same GPU which leaves any other GPU's doing nothing. For me at least nothing has changed :(

For sh#%s & giggles I even tried to changing the command to -d 1 in the job_160.xml file and another time tried pausing the WU and changing it in job.xml file in the slot directory but with the same result. As far as boinc is aware all is working as it should be with a WU running on each device but in reality there both being crunched by the same GPU.
ID: 5859 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile Dave GPU

Send message
Joined: 3 Dec 14
Posts: 9
Credit: 451,589,695
RAC: 6,648,656
Message 5860 - Posted: 16 Jul 2017, 15:32:49 UTC - in response to Message 5859.  

For me the GPU app still only works on one GPU, allowing two WU's to run only runs them both on the same GPU which leaves any other GPU's doing nothing. For me at least nothing has changed :(

For sh#%s & giggles I even tried to changing the command to -d 1 in the job_160.xml file and another time tried pausing the WU and changing it in job.xml file in the slot directory but with the same result. As far as boinc is aware all is working as it should be with a WU running on each device but in reality there both being crunched by the same GPU.



I also did not have much luck with running 2 GPUs, but hopeful that the OpenCL/ATI version of GPU app will allow you to run
both NV & ATI GPUs cards in same rig.
ID: 5860 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Profile TJM
Project administrator
Project developer
Project scientist
Avatar

Send message
Joined: 25 Aug 07
Posts: 843
Credit: 70,402,822
RAC: 388,121
Message 5861 - Posted: 16 Jul 2017, 15:33:43 UTC - in response to Message 5859.  


For sh#%s & giggles I even tried to changing the command to -d 1 in the job_160.xml file


This won't work, as the wrapper adds -d on the fly to the command line that's already in the job file and it always does that, defaults to GPU 0.
Which host id is that ? The wrapper writes command line used to run app to the stderr, so it can be seen online in result details.

You could try it outside of the BOINC, just copy the files from slot folder running GPU app somewhere, and create a test bat file:

wrappergpu_1.08_windows_x86_64__cuda_fermi.exe --device 1
pause

the wrapper will read the job file and should add the number passed after --device to command line.
I've just tested it and it does that on my system, but I do not have second GPU.


M4 Project homepage
M4 Project wiki
ID: 5861 · Rating: 0 · rate: Rate + / Rate - Report as offensive    Reply Quote
Previous · 1 . . . 4 · 5 · 6 · 7 · 8 · 9 · 10 . . . 11 · Next

Message boards : Number crunching : A GPU version of Enigma software




Copyright © 2017 TJM